Visual Studio 2017 with oxygine problem



  • Hello everyone, i want to start with oxygine, but have a problem with first compile.
    Couse, iv got thoes errors:
    unresolved external symbol __imp__fprintf
    unresolved external symbol __imp____iob_func

    compilator said, that file oxygine_d_lib couse those errors.

    anyone know how to fix that?


  • administrators

    Hi, could you try oxygine from "ox-move" branch?
    https://github.com/oxygine/oxygine-framework/tree/ox-move



  • Sure, iv compiled it and visual 2017 (Visual Studio 2017 (v141)) shows me that cant find every single .h file from this engine. This shows, when i set for windows sdk 8.1.

    But.. when i set up on windows sdk 10.(...)
    then its shows error while debugging
    Run-Time Check Failure #0 - The value of ESP was not properly saved across a function call. This is usually a result of calling a function declared with one calling convention with a function pointer declared with a different calling convention.

    iv installed visual studio 2017 specialy for oxygine. On visual studio 2013 same message:
    Run-Time Check Failure #0 - The value of ESP was not properly saved across a function call. This is usually a result of calling a function declared with one calling convention with a function pointer declared with a different calling convention.

    Okay, maybe we do this other way, can you tell me, what i need to install, to use your engine?
    Like what windows you recomand,version of visual with what features etc.
    What youv used to create oxygine? I will try install same setting, and maybe then it will compiled.

    Couse i have a windows 7, visual studio 2013 proffesional, visual studio 2017 comunity. Ofc iv installed python, create solution using python command on gen_template.py etc. Done everything you said on videos, and wiki. Maybe i make some misstake, maybe its problem with a settings.


  • administrators

    unfortunately I can't reproduce any your errors.
    I can succesfully build examples and project created with gen_template


  • administrators

    Just installed VS2017 community. And succesfully launched examples.
    One thing I only changed is select platform toolset V141 for example and oxygine project.



  • Okay then, i will try reinstall visual studio, and try once more. Will write soon.


Log in to reply
 

Looks like your connection to Oxygine was lost, please wait while we try to reconnect.